Microsoft recently released a comprehensive patch that eliminates three security vulnerabilities in Microsoft Internet Explorer, including IE 4.0, IE 4.01, IE 5.0 and IE 5.01. The patch essentially protects the computers of Web site users from malicious Web site operators. In the Frame Domain Verification vulnerability, Web site operators might be able to read, but not to change or add, files on visiting users’ computers. The Unauthorized Cookie Access vulnerability might let a Web site operator access cookies belonging to a visiting user. The Malformed Component Attribute vulnerability can let a Web site operator run code of his choice on the computer of a visiting user. These security vulnerabilities are unrelated to each other, except they all occur in the same .dll. Fixes for all three issues are packaged together for customer convenience. The patch is available at and Additional security patches are available at the Microsoft Download Center \['security_patch'&OpSysID=1\].